Eclipse 3 5 Access Internet With Ntlm2 Proxy

Eclipse 3.5 failed with NTLMv2 proxy authorization

[Net] You can't update Eclipse 3.5 behind the proxy
https://bugs.eclipse.org/bugs/show_bug.cgi?id=281472

Galileo access internet with HttpClient 3.1, which is not support NTLMv2, for the problem of MS license, removed support from HttpClient 3.0.

This problem can be avoid with ECF Filetransfer Support for NTLMv2 Proxies
http://wiki.eclipse.org/ECF_Filetransfer_Support_for_NTLMv2_Proxies

Adding the following option to the tail of eclipse.ini

-Dorg.eclipse.ecf.provider.filetransfer.excludeContributors=org.eclipse.ecf.provider.filetransfer.httpclient
-Dhttp.proxyPort=8080
-Dhttp.proxyHost=myproxy
-Dhttp.proxyUser=mydomain\myusername
-Dhttp.proxyPassword=mypassword
-Dhttp.nonProxyHosts=localhost|127.0.0.1

the line #1 exclude HttpClient
the line #2 setup proxy

[Net] HTTP Proxy Authentication Required
https://bugs.eclipse.org/bugs/show_bug.cgi?id=281384

the problem is fixed from Eclipse 3.5.2

Reference: